summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/File-Flat/File-Flat-1.40.0-r1.ebuild')
-rw-r--r--dev-perl/File-Flat/File-Flat-1.40.0-r1.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/dev-perl/File-Flat/File-Flat-1.40.0-r1.ebuild b/dev-perl/File-Flat/File-Flat-1.40.0-r1.ebuild
index f0ece65d6c89..c46442741031 100644
--- a/dev-perl/File-Flat/File-Flat-1.40.0-r1.ebuild
+++ b/dev-perl/File-Flat/File-Flat-1.40.0-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-MODULE_AUTHOR=ADAMK
-MODULE_VERSION=1.04
+DIST_AUTHOR=ADAMK
+DIST_VERSION=1.04
inherit perl-module
DESCRIPTION="Implements a flat filesystem"
@@ -24,4 +24,8 @@ RDEPEND=">=dev-perl/Class-Autouse-1
>=dev-perl/prefork-0.02"
DEPEND="${RDEPEND}"
-SRC_TEST="do"
+src_prepare() {
+ sed -i -e 's/use inc::Module::Install;/use lib q[.]; use inc::Module::Install;/' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+ perl-module_src_prepare
+}