summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Finance-Quote/Finance-Quote-1.370.0.ebuild')
-rw-r--r--dev-perl/Finance-Quote/Finance-Quote-1.370.0.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-perl/Finance-Quote/Finance-Quote-1.370.0.ebuild b/dev-perl/Finance-Quote/Finance-Quote-1.370.0.ebuild
new file mode 100644
index 000000000000..3b5c6837a194
--- /dev/null
+++ b/dev-perl/Finance-Quote/Finance-Quote-1.370.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=ECOCODE
+MODULE_VERSION=1.37
+inherit perl-module
+
+DESCRIPTION="Get stock and mutual fund quotes from various exchanges"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+# virtual/perl-Data-Dumper currently commented out in the code
+
+RDEPEND="
+ dev-perl/CGI
+ virtual/perl-Carp
+ dev-perl/DateTime
+ virtual/perl-Encode
+ virtual/perl-Exporter
+ dev-perl/HTML-Parser
+ dev-perl/HTML-TableExtract
+ dev-perl/HTML-Tree
+ dev-perl/HTTP-Cookies
+ dev-perl/HTTP-Message
+ dev-perl/JSON
+ dev-perl/LWP-Protocol-https
+ dev-perl/libwww-perl
+ dev-perl/Mozilla-CA
+ virtual/perl-Time-Piece
+ dev-perl/URI
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Spec
+ virtual/perl-Test-Simple
+ dev-perl/Test-Pod
+ dev-perl/Perl-Critic-Dynamic
+ )
+"
+
+SRC_TEST="do parallel"