summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/GD/GD-2.560.0.ebuild')
-rw-r--r--dev-perl/GD/GD-2.560.0.ebuild78
1 files changed, 78 insertions, 0 deletions
diff --git a/dev-perl/GD/GD-2.560.0.ebuild b/dev-perl/GD/GD-2.560.0.ebuild
new file mode 100644
index 000000000000..f412f884c8b8
--- /dev/null
+++ b/dev-perl/GD/GD-2.560.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=LDS
+DIST_VERSION=2.56
+inherit perl-module
+
+DESCRIPTION="Interface to Thomas Boutell's gd library"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="animgif gif jpeg png truetype xpm"
+
+RDEPEND="
+ virtual/perl-Math-Complex
+ >=media-libs/gd-2.0.33
+ png? (
+ media-libs/gd[png]
+ media-libs/libpng:0
+ sys-libs/zlib
+ )
+ jpeg? (
+ media-libs/gd[jpeg]
+ virtual/jpeg:0
+ )
+ truetype? (
+ media-libs/gd[truetype]
+ media-libs/freetype:2
+ )
+ xpm? (
+ media-libs/gd[xpm]
+ x11-libs/libXpm
+ )
+ gif? ( media-libs/giflib )
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-CBuilder
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+PREFER_BUILDPL="no"
+
+src_prepare(){
+ perl-module_src_prepare
+ sed -i "s/use Getopt::Long;/use Getopt::Long qw(:config pass_through);/" \
+ "${S}"/Makefile.PL || die
+}
+
+src_configure() {
+ local myconf
+ use gif && use animgif && myconf+=",ANIMGIF"
+ use jpeg && myconf+=",JPEG"
+ use truetype && myconf+=",FT"
+ use png && myconf+=",PNG"
+ use xpm && myconf+=",XPM"
+ use gif && myconf+=",GIF"
+ myconf="-options '${myconf:1}'"
+ perl-module_src_configure
+}
+
+src_test() {
+ if use png || use jpeg || use gif ; then
+ if has_version ">=media-libs/jpeg-7" || \
+ has_version "media-libs/libjpeg-turbo" ; then
+ # https://rt.cpan.org/Public/Bug/Display.html?id=49053
+ ewarn "Tests fail with >=media-libs/jpeg-7 or media-libs/libjpeg-turbo. Skipping tests..."
+ return
+ fi
+ perl-module_src_test
+ else
+ ewarn "The test fails if neither of png, jpeg, gif is in USE!"
+ ewarn "Skipping tests..."
+ fi
+}
+mydoc="GD.html"