summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Gearman-Client-Async/Gearman-Client-Async-0.940.0-r3.ebuild')
-rw-r--r--dev-perl/Gearman-Client-Async/Gearman-Client-Async-0.940.0-r3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/Gearman-Client-Async/Gearman-Client-Async-0.940.0-r3.ebuild b/dev-perl/Gearman-Client-Async/Gearman-Client-Async-0.940.0-r3.ebuild
new file mode 100644
index 000000000000..c7409a928ef6
--- /dev/null
+++ b/dev-perl/Gearman-Client-Async/Gearman-Client-Async-0.940.0-r3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=BRADFITZ
+DIST_VERSION=0.94
+inherit perl-module
+
+DESCRIPTION="Asynchronous client module for Gearman for Danga::Socket applications"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ >=dev-perl/Gearman-1.70.0
+ >=dev-perl/Danga-Socket-1.570.0
+"
+BDEPEND="${RDEPEND}
+ test? ( dev-perl/Gearman-Server )
+"
+
+DIST_TEST="do"
+
+src_test() {
+ local BADTESTS=(
+ # blocks forever
+ t/err1.t
+ # https://rt.cpan.org/Public/Bug/Display.html?id=87063
+ t/err3.t
+ )
+ perl_rm_files "${BADTESTS[@]}"
+ perl-module_src_test
+}