summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Getopt-GUI-Long/Getopt-GUI-Long-0.930.0-r3.ebuild')
-rw-r--r--dev-perl/Getopt-GUI-Long/Getopt-GUI-Long-0.930.0-r3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-perl/Getopt-GUI-Long/Getopt-GUI-Long-0.930.0-r3.ebuild b/dev-perl/Getopt-GUI-Long/Getopt-GUI-Long-0.930.0-r3.ebuild
new file mode 100644
index 000000000000..e0a59e3b4c44
--- /dev/null
+++ b/dev-perl/Getopt-GUI-Long/Getopt-GUI-Long-0.930.0-r3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=HARDAKER
+DIST_VERSION=0.93
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Auto-GUI extending Getopt::Long"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="
+ virtual/perl-File-Temp
+ virtual/perl-Getopt-Long
+"
+
+src_test() {
+ local MODULES=(
+ "Getopt::GUI::Long ${DIST_VERSION}"
+ )
+ local failed=()
+ for dep in "${MODULES[@]}"; do
+ ebegin "Compile testing ${dep}"
+ perl -Mblib="${S}" -M"${dep} ()" -e1
+ eend $? || failed+=( "$dep" )
+ done
+ if [[ ${failed[@]} ]]; then
+ echo
+ eerror "One or more modules failed compile:";
+ for dep in "${failed[@]}"; do
+ eerror " ${dep}"
+ done
+ die "Failing due to module compilation errors";
+ fi
+ perl-module_src_test
+}