summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Getopt-Long-Descriptive')
-rw-r--r--dev-perl/Getopt-Long-Descriptive/Getopt-Long-Descriptive-0.100.0.ebuild37
-rw-r--r--dev-perl/Getopt-Long-Descriptive/Manifest1
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-perl/Getopt-Long-Descriptive/Getopt-Long-Descriptive-0.100.0.ebuild b/dev-perl/Getopt-Long-Descriptive/Getopt-Long-Descriptive-0.100.0.ebuild
new file mode 100644
index 000000000000..6f0d25ae0151
--- /dev/null
+++ b/dev-perl/Getopt-Long-Descriptive/Getopt-Long-Descriptive-0.100.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=RJBS
+DIST_VERSION=0.100
+inherit perl-module
+
+DESCRIPTION="Getopt::Long with usage text"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~ppc-aix ~ppc-macos ~x86-solaris"
+IUSE="test minimal"
+
+CONFLICTS="!<dev-perl/MooseX-Getopt-0.660.0"
+# File::Basename -> perl
+# List::Util, Scalar::Util -> perl-Scalar-List-Utils
+# Sub::Exporter::Util -> Sub-Exporter
+RDEPEND="${CONFLICTS}
+ virtual/perl-Carp
+ >=virtual/perl-Getopt-Long-2.330.0
+ >=dev-perl/Params-Validate-0.970.0
+ virtual/perl-Scalar-List-Utils
+ >=dev-perl/Sub-Exporter-0.972.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ !minimal? ( >=virtual/perl-CPAN-Meta-2.120.900 )
+ >=dev-perl/CPAN-Meta-Check-0.11.0
+ virtual/perl-File-Spec
+ dev-perl/Test-Fatal
+ >=virtual/perl-Test-Simple-0.960.0
+ >=dev-perl/Test-Warnings-0.5.0
+ )
+"
diff --git a/dev-perl/Getopt-Long-Descriptive/Manifest b/dev-perl/Getopt-Long-Descriptive/Manifest
index 0570af8d2f25..44058f49ca3d 100644
--- a/dev-perl/Getopt-Long-Descriptive/Manifest
+++ b/dev-perl/Getopt-Long-Descriptive/Manifest
@@ -1,2 +1,3 @@
DIST Getopt-Long-Descriptive-0.097.tar.gz 26399 SHA256 a6e484962727ae2d882d5d35c5bedd48bc13730a7e4c739a7daa74f525422883 SHA512 9b1a11bce5a64b0dbae93d410593c6411790db8eac1169eb1703fdd4b0bffc0cb0ce12fd02c3de0b4fea98151bcc98af55cf46d84d658c8292291bf3baf5d28d WHIRLPOOL 19c2185574a3cadc8d1ca01ca4ab7c9dbb5c7938573a471f464fa5f937379248fc0ff3da71ef23b0a14fc67409e3268858b4e5ea65e71798b042802ef6e81854
DIST Getopt-Long-Descriptive-0.099.tar.gz 29651 SHA256 fc4d1ed0bf12abc3d01ba38b0376c1b0fe6c6e59152b61b5f500a1e3f7c8c5e9 SHA512 3b6fdf06eab25f53c5624e42a8024d059d1ee1c33361184a1d45fc5f0f9b521ad0749916ca7ec7d9561bc2c297adba520ff1fd5efa6706ca480697fad71290da WHIRLPOOL 938e7585b014fd08b88e492b1168aaef4810f7e1906bf0a2825c47048e0f92237ed6bd55bd4f0deb2244b0b3f25c8495add77a3a33a6c43503087beab3a902cb
+DIST Getopt-Long-Descriptive-0.100.tar.gz 31366 SHA256 1451e79310d1630de37690e3aba5c38ea5f01a486c5a43f0cd95bef2a02dffb6 SHA512 0efd6f707487b9b44d5c3b5c9e46c3718546e44bf1b66c198be6ebfc922e7bdb23a9c57c5a9c0985dc3769617141696750e1bd982457247b679e3bdb5f9f16c7 WHIRLPOOL 48f3518025cb538cec37b4a88f5618b4ad8335261a479294d684aca2f781c3f5f5f92258993e978e6852c84d60964ee92494973acb0f8b725ecbd51775190653