summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/HTML-Object/HTML-Object-2.30.ebuild')
-rw-r--r--dev-perl/HTML-Object/HTML-Object-2.30.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/HTML-Object/HTML-Object-2.30.ebuild b/dev-perl/HTML-Object/HTML-Object-2.30.ebuild
new file mode 100644
index 000000000000..27aa64c383da
--- /dev/null
+++ b/dev-perl/HTML-Object/HTML-Object-2.30.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit perl-module
+
+MY_P=libhtmlobject-perl-${PV}
+
+DESCRIPTION="A HTML development and delivery Perl Module"
+SRC_URI="mirror://sourceforge/htmlobject/${MY_P}.tar.gz"
+HOMEPAGE="http://htmlobject.sourceforge.net"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="examples"
+
+RDEPEND="dev-perl/Data-FormValidator
+ dev-perl/Date-Manip"
+BDEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_test() {
+ TZ=UTC perl-module_src_test
+}
+
+src_install() {
+ perl-module_src_install
+ if use examples; then
+ docompress -x usr/share/doc/${PF}/examples/
+ insinto usr/share/doc/${PF}
+ doins -r examples/
+ fi
+}