summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/MCE/MCE-1.827.0.ebuild')
-rw-r--r--dev-perl/MCE/MCE-1.827.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-perl/MCE/MCE-1.827.0.ebuild b/dev-perl/MCE/MCE-1.827.0.ebuild
new file mode 100644
index 000000000000..39184ec6d738
--- /dev/null
+++ b/dev-perl/MCE/MCE-1.827.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MARIOROY
+DIST_VERSION=1.827
+inherit perl-module
+
+DESCRIPTION="Many-Core Engine providing parallel processing capabilities"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test +sereal"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-File-Path
+ virtual/perl-Getopt-Long
+ virtual/perl-IO
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-Socket
+ >=virtual/perl-Storable-2.40.0
+ virtual/perl-Time-HiRes
+ sereal? (
+ >=dev-perl/Sereal-Encoder-3.15.0
+ >=dev-perl/Sereal-Decoder-3.15.0
+ )
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( virtual/perl-Test-Simple )
+"