summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Math-Random-ISAAC-XS/Math-Random-ISAAC-XS-1.4.0-r1.ebuild')
-rw-r--r--dev-perl/Math-Random-ISAAC-XS/Math-Random-ISAAC-XS-1.4.0-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-perl/Math-Random-ISAAC-XS/Math-Random-ISAAC-XS-1.4.0-r1.ebuild b/dev-perl/Math-Random-ISAAC-XS/Math-Random-ISAAC-XS-1.4.0-r1.ebuild
new file mode 100644
index 000000000000..79178c9d561a
--- /dev/null
+++ b/dev-perl/Math-Random-ISAAC-XS/Math-Random-ISAAC-XS-1.4.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=JAWNSY
+MODULE_VERSION=1.004
+inherit perl-module
+
+DESCRIPTION="C implementation of the ISAAC PRNG algorithm"
+
+LICENSE="|| ( public-domain Artistic Artistic-2 GPL-1 GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND="dev-perl/Math-Random-ISAAC"
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? (
+ dev-perl/Test-NoWarnings
+ )"
+
+SRC_TEST="do"