summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Net-PcapUtils/Net-PcapUtils-0.10.0-r2.ebuild')
-rw-r--r--dev-perl/Net-PcapUtils/Net-PcapUtils-0.10.0-r2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-perl/Net-PcapUtils/Net-PcapUtils-0.10.0-r2.ebuild b/dev-perl/Net-PcapUtils/Net-PcapUtils-0.10.0-r2.ebuild
new file mode 100644
index 000000000000..f6f9f7912ed7
--- /dev/null
+++ b/dev-perl/Net-PcapUtils/Net-PcapUtils-0.10.0-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=TIMPOTTER
+DIST_VERSION=0.01
+inherit perl-module
+
+DESCRIPTION="Utility routines for use with Net::Pcap"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-perl/Net-Pcap"
+DEPEND="${RDEPEND}"
+PATCHES=("${FILESDIR}/${PN}-0.01-testsuite.patch")
+
+src_test() {
+ if [[ $EUID != 0 ]]; then
+ elog "Some tests require root privileges. For details, see:"
+ elog "https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/${CATEGORY}/${PN}"
+ fi
+ perl-module_src_test
+}