summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Net-SSLeay/Net-SSLeay-1.900.0.ebuild')
-rw-r--r--dev-perl/Net-SSLeay/Net-SSLeay-1.900.0.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/dev-perl/Net-SSLeay/Net-SSLeay-1.900.0.ebuild b/dev-perl/Net-SSLeay/Net-SSLeay-1.900.0.ebuild
deleted file mode 100644
index 7aa8353d6813..000000000000
--- a/dev-perl/Net-SSLeay/Net-SSLeay-1.900.0.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DIST_AUTHOR=CHRISN
-DIST_VERSION=1.90
-DIST_EXAMPLES=("examples/*")
-inherit multilib perl-module
-
-DESCRIPTION="Perl extension for using OpenSSL"
-
-LICENSE="Artistic-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="minimal examples"
-
-RDEPEND="
- dev-libs/openssl:0=
- virtual/perl-MIME-Base64
-"
-BDEPEND="${RDEPEND}
- virtual/perl-ExtUtils-MakeMaker
- test? (
- !minimal? (
- dev-perl/Test-Exception
- dev-perl/Test-Warn
- dev-perl/Test-NoWarnings
- )
- virtual/perl-Test-Simple
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.88-fix-network-tests.patch"
- "${FILESDIR}/${PN}-1.88-fix-libdir.patch"
-)
-
-PERL_RM_FILES=(
- # Hateful author tests
- 't/local/01_pod.t'
- 't/local/02_pod_coverage.t'
- 't/local/kwalitee.t'
-)
-
-src_configure() {
- if use test && has network ${DIST_TEST_OVERRIDE:-${DIST_TEST:-do parallel}}; then
- export NETWORK_TESTS=yes
- else
- use test && einfo "Network tests will be skipped without DIST_TEST_OVERRIDE=~network"
- export NETWORK_TESTS=no
- fi
- export LIBDIR=$(get_libdir)
- perl-module_src_configure
-}
-
-src_compile() {
- mymake=(
- OPTIMIZE="${CFLAGS}"
- OPENSSL_PREFIX="${EPREFIX}"/usr
- )
- perl-module_src_compile
-}