summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Specio')
-rw-r--r--dev-perl/Specio/Manifest1
-rw-r--r--dev-perl/Specio/Specio-0.350.0.ebuild40
-rw-r--r--dev-perl/Specio/metadata.xml7
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-perl/Specio/Manifest b/dev-perl/Specio/Manifest
index e6641a423d95..50b6e48d5deb 100644
--- a/dev-perl/Specio/Manifest
+++ b/dev-perl/Specio/Manifest
@@ -1,2 +1,3 @@
DIST Specio-0.31.tar.gz 82791 SHA256 ef4a7c4856032cb1d725f96c06de2a25d1edaef8812c1f86d13e55ecee0183f9 SHA512 1d16ff9aeb3e2026c23928db64587e42f74b2488b7aeef6ee7b03ec0542dd4986cca25b3206d7d50e54724d5d3e04e8ab268808d42ff32f179ea719ca6821544 WHIRLPOOL f81df5c29ca77c97541ab584ff3dd51c39d49c164fe8aae4bec52262ac4805d0cef273708004d695670abe32dd02b893fef773a49922b1677a2540e4f252ec9b
DIST Specio-0.32.tar.gz 83679 SHA256 07544e0e52c252d480714edd8256447e7ec5762c99571c305ca2895e58d8f949 SHA512 6803089d5f80d9c7b811c0bddb6937228cbb95a0876424a678b76f38609b32220a2ffee63b904535baf741ddbffb880999b3ea49e41d34731ed83394b5d0628b WHIRLPOOL 6620a63030d263d0177823bd2482f9c7aa572c8f62975b929655a56d0060dbbfd11baa7489106c6334121cf5d8890bfda8cdd6da0cf065cc3de424e50ff7bbce
+DIST Specio-0.35.tar.gz 94969 SHA256 5c75f366594f0d2a5a39ca9cf31b8dfa0e2564c148aa0e2805fd263530ceffa5 SHA512 1a765e7bb2d6b8ddfd18a6cc75108a9237f63acba929c8b94767f336932626a4afb64a4aec96c3a7d518764df6456051fbea4d337a3ce79c9bea25579cca7015 WHIRLPOOL 04d4bbc02c251dbf3f2e392801ee7a5c1b2d9059f6e03584e8500031038cd3240e1d29fb9716b4b64ffbe58c59aa4c9046da8c210be9eb9524fd86b67c49f722
diff --git a/dev-perl/Specio/Specio-0.350.0.ebuild b/dev-perl/Specio/Specio-0.350.0.ebuild
new file mode 100644
index 000000000000..f0c34189bd38
--- /dev/null
+++ b/dev-perl/Specio/Specio-0.350.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=DROLSKY
+DIST_VERSION=0.35
+inherit perl-module
+
+DESCRIPTION="Type constraints and coercions for Perl"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test minimal"
+
+RDEPEND="
+ !minimal? ( >=dev-perl/Ref-Util-0.112.0 )
+ virtual/perl-Carp
+ dev-perl/Devel-StackTrace
+ dev-perl/Eval-Closure
+ virtual/perl-Exporter
+ virtual/perl-IO
+ dev-perl/MRO-Compat
+ dev-perl/Module-Runtime
+ >=dev-perl/Role-Tiny-1.3.3
+ >=virtual/perl-Scalar-List-Utils-1.330.0
+ virtual/perl-Storable
+ dev-perl/Test-Fatal
+ >=virtual/perl-Test-Simple-0.960.0
+ virtual/perl-parent
+ >=virtual/perl-version-0.830.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ dev-perl/Test-Needs
+ )
+"
+mydoc="TODO.md"
diff --git a/dev-perl/Specio/metadata.xml b/dev-perl/Specio/metadata.xml
index 270851de65e0..2328595eef1a 100644
--- a/dev-perl/Specio/metadata.xml
+++ b/dev-perl/Specio/metadata.xml
@@ -24,6 +24,8 @@
<remote-id type="cpan-module">Specio::Constraint::Role::Interface</remote-id>
<remote-id type="cpan-module">Specio::Constraint::Role::IsaType</remote-id>
<remote-id type="cpan-module">Specio::Constraint::Simple</remote-id>
+ <remote-id type="cpan-module">Specio::Constraint::Structurable</remote-id>
+ <remote-id type="cpan-module">Specio::Constraint::Structured</remote-id>
<remote-id type="cpan-module">Specio::Constraint::Union</remote-id>
<remote-id type="cpan-module">Specio::Declare</remote-id>
<remote-id type="cpan-module">Specio::DeclaredAt</remote-id>
@@ -34,10 +36,15 @@
<remote-id type="cpan-module">Specio::Library::Numeric</remote-id>
<remote-id type="cpan-module">Specio::Library::Perl</remote-id>
<remote-id type="cpan-module">Specio::Library::String</remote-id>
+ <remote-id type="cpan-module">Specio::Library::Structured</remote-id>
+ <remote-id type="cpan-module">Specio::Library::Structured::Dict</remote-id>
+ <remote-id type="cpan-module">Specio::Library::Structured::Map</remote-id>
+ <remote-id type="cpan-module">Specio::Library::Structured::Tuple</remote-id>
<remote-id type="cpan-module">Specio::OO</remote-id>
<remote-id type="cpan-module">Specio::PartialDump</remote-id>
<remote-id type="cpan-module">Specio::Registry</remote-id>
<remote-id type="cpan-module">Specio::Role::Inlinable</remote-id>
+ <remote-id type="cpan-module">Specio::Subs</remote-id>
<remote-id type="cpan-module">Specio::TypeChecks</remote-id>
<remote-id type="cpan-module">Test::Specio</remote-id>
</upstream>