summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Test-Regexp/Test-Regexp-2017040101.0.0.ebuild')
-rw-r--r--dev-perl/Test-Regexp/Test-Regexp-2017040101.0.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/Test-Regexp/Test-Regexp-2017040101.0.0.ebuild b/dev-perl/Test-Regexp/Test-Regexp-2017040101.0.0.ebuild
new file mode 100644
index 000000000000..309b73a56281
--- /dev/null
+++ b/dev-perl/Test-Regexp/Test-Regexp-2017040101.0.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit versionator
+
+DIST_AUTHOR=ABIGAIL
+DIST_VERSION=$(get_major_version)
+
+inherit perl-module
+
+DESCRIPTION="Provide commonly requested regular expressions"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+DEPEND="
+ test? ( >=virtual/perl-Test-Simple-1.1.14 )
+ virtual/perl-ExtUtils-MakeMaker
+"
+RDEPEND="
+ virtual/perl-Test-Simple
+ virtual/perl-Exporter
+"
+
+src_test() {
+ # Omit code coverage / documentation tests
+ perl_rm_files t/{950,960,980,981,982}*.t
+
+ perl-module_src_test
+}