summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Test-Warnings/Test-Warnings-0.33.0.ebuild')
-rw-r--r--dev-perl/Test-Warnings/Test-Warnings-0.33.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-perl/Test-Warnings/Test-Warnings-0.33.0.ebuild b/dev-perl/Test-Warnings/Test-Warnings-0.33.0.ebuild
new file mode 100644
index 000000000000..ce47083fd74d
--- /dev/null
+++ b/dev-perl/Test-Warnings/Test-Warnings-0.33.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=ETHER
+DIST_VERSION=0.033
+inherit perl-module
+
+DESCRIPTION='Test for warnings and the lack of them'
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="suggested"
+
+RDEPEND="
+ !<dev-perl/File-pushd-1.4.0
+ virtual/perl-Carp
+ virtual/perl-Exporter
+ virtual/perl-Test-Simple
+ virtual/perl-parent
+"
+BDEPEND="
+ ${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.300.0
+ test? (
+ suggested? (
+ >=dev-perl/CPAN-Meta-Check-0.11.0
+ )
+ >=virtual/perl-CPAN-Meta-2.120.900
+ virtual/perl-File-Spec
+ >=virtual/perl-Test-Simple-0.940.0
+ virtual/perl-if
+ virtual/perl-version
+ )
+"