summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Text-Password-Pronounceable/Text-Password-Pronounceable-0.300.0-r2.ebuild')
-rw-r--r--dev-perl/Text-Password-Pronounceable/Text-Password-Pronounceable-0.300.0-r2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-perl/Text-Password-Pronounceable/Text-Password-Pronounceable-0.300.0-r2.ebuild b/dev-perl/Text-Password-Pronounceable/Text-Password-Pronounceable-0.300.0-r2.ebuild
new file mode 100644
index 000000000000..a920fab3be8d
--- /dev/null
+++ b/dev-perl/Text-Password-Pronounceable/Text-Password-Pronounceable-0.300.0-r2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_VERSION=0.30
+DIST_AUTHOR=TSIBLEY
+inherit perl-module
+
+DESCRIPTION="Generate pronounceable passwords"
+
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+
+src_prepare() {
+ sed -i -e 's/use inc::Module::Install;/use lib q[.]; use inc::Module::Install;/' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+ perl-module_src_prepare
+}
+
+src_test() {
+ perl_rm_files t/99pod.t t/99pod-coverage.t
+ perl-module_src_test
+}