summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Types-Path-Tiny/Types-Path-Tiny-0.6.0.ebuild')
-rw-r--r--dev-perl/Types-Path-Tiny/Types-Path-Tiny-0.6.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/Types-Path-Tiny/Types-Path-Tiny-0.6.0.ebuild b/dev-perl/Types-Path-Tiny/Types-Path-Tiny-0.6.0.ebuild
new file mode 100644
index 000000000000..21b2f429b05d
--- /dev/null
+++ b/dev-perl/Types-Path-Tiny/Types-Path-Tiny-0.6.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=DAGOLDEN
+DIST_VERSION=0.006
+inherit perl-module
+
+DESCRIPTION="Path::Tiny types and coercions for Moose and Moo"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-perl/Path-Tiny
+ >=dev-perl/Type-Tiny-0.8.0
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.170.0
+ test? (
+ virtual/perl-File-Spec
+ >=virtual/perl-File-Temp-0.180.0
+ dev-perl/File-pushd
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"