summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/WWW-Mechanize/WWW-Mechanize-1.750.0.ebuild')
-rw-r--r--dev-perl/WWW-Mechanize/WWW-Mechanize-1.750.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-perl/WWW-Mechanize/WWW-Mechanize-1.750.0.ebuild b/dev-perl/WWW-Mechanize/WWW-Mechanize-1.750.0.ebuild
new file mode 100644
index 000000000000..be5736f1b556
--- /dev/null
+++ b/dev-perl/WWW-Mechanize/WWW-Mechanize-1.750.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=ETHER
+MODULE_VERSION=1.75
+inherit perl-module
+
+DESCRIPTION="Handy web browsing in a Perl object"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/IO-Socket-SSL
+ || (
+ ( >dev-perl/libwww-perl-6 dev-perl/HTML-Form )
+ <dev-perl/libwww-perl-6
+ )
+ >=dev-perl/URI-1.36
+ >=dev-perl/HTML-Parser-3.34
+ dev-perl/HTML-Tree
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-perl/PadWalker
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ dev-perl/Test-Exception
+ dev-perl/Test-NoWarnings
+ dev-perl/Test-Taint
+ >=dev-perl/Test-Warn-0.11
+ dev-perl/Test-Memory-Cycle
+ dev-perl/HTTP-Server-Simple
+ )
+"
+
+# configure to run the local tests, but not the ones which access the Internet
+myconf="--local --nolive"
+
+SRC_TEST=do