summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/perl-ldap/perl-ldap-0.640.0.ebuild')
-rw-r--r--dev-perl/perl-ldap/perl-ldap-0.640.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/perl-ldap/perl-ldap-0.640.0.ebuild b/dev-perl/perl-ldap/perl-ldap-0.640.0.ebuild
new file mode 100644
index 000000000000..2e4b005520fd
--- /dev/null
+++ b/dev-perl/perl-ldap/perl-ldap-0.640.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=MARSCHAP
+MODULE_VERSION=0.64
+inherit perl-module
+
+DESCRIPTION="A collection of perl modules which provide an object-oriented interface to LDAP servers"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="sasl xml ssl"
+
+RDEPEND="
+ dev-perl/Convert-ASN1
+ dev-perl/URI
+ sasl? (
+ virtual/perl-Digest-MD5
+ dev-perl/Authen-SASL
+ )
+ xml? (
+ dev-perl/XML-Parser
+ dev-perl/XML-SAX
+ dev-perl/XML-SAX-Writer
+ )
+ ssl? (
+ >=dev-perl/IO-Socket-SSL-1.26
+ )"
+DEPEND="${RDEPEND}"
+
+#SRC_TEST=do