summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.10.11.ebuild')
-rw-r--r--dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.10.11.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.10.11.ebuild b/dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.10.11.ebuild
new file mode 100644
index 000000000000..eb4747a42cf2
--- /dev/null
+++ b/dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.10.11.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit php-pear-r2
+
+DESCRIPTION="Create and manipulate mime messages with PHP"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-php/PEAR-PEAR )"
+
+src_test() {
+ # Requires the "pear" executable from dev-php/PEAR-PEAR.
+ pear run-tests tests || die
+
+ # The command succeeds regardless of whether or not the test suite
+ # passed, but this file is only written when there was a failure.
+ [[ -f run-tests.log ]] && die "test suite failed"
+}