summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/PEAR-XML_RSS/PEAR-XML_RSS-1.1.0-r2.ebuild')
-rw-r--r--dev-php/PEAR-XML_RSS/PEAR-XML_RSS-1.1.0-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-php/PEAR-XML_RSS/PEAR-XML_RSS-1.1.0-r2.ebuild b/dev-php/PEAR-XML_RSS/PEAR-XML_RSS-1.1.0-r2.ebuild
new file mode 100644
index 000000000000..d26ab5240242
--- /dev/null
+++ b/dev-php/PEAR-XML_RSS/PEAR-XML_RSS-1.1.0-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit php-pear-r2
+
+DESCRIPTION="PHP parser for RDF and RSS documents"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="amd64 arm ~hppa ppc64 ~s390 sparc x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-php/PEAR-XML_Parser-1.3.8-r1"
+BDEPEND="test? ( ${RDEPEND} dev-php/phpunit )"
+
+PATCHES=( "${FILESDIR}/XML_RSS-1.1.0-php8.patch" )
+
+src_prepare() {
+ default
+ sed -i \
+ -e 's/_Framework_/\\Framework\\/' \
+ -e 's/_TextUI_/\\TextUI\\/' \
+ tests/*.php
+}
+
+src_test() {
+ phpunit --bootstrap "${S}/XML/RSS.php" \
+ --cache-result-file="${T}/test-results.cache" tests || die
+}