summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/PHP_Timer/PHP_Timer-2.1.2-r1.ebuild')
-rw-r--r--dev-php/PHP_Timer/PHP_Timer-2.1.2-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-php/PHP_Timer/PHP_Timer-2.1.2-r1.ebuild b/dev-php/PHP_Timer/PHP_Timer-2.1.2-r1.ebuild
new file mode 100644
index 000000000000..a0785cb680f7
--- /dev/null
+++ b/dev-php/PHP_Timer/PHP_Timer-2.1.2-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="php-timer"
+
+DESCRIPTION="Utility class for timing"
+HOMEPAGE="https://phpunit.de"
+SRC_URI="https://github.com/sebastianbergmann/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ >=dev-lang/php-7.1:*"
+
+src_install() {
+ insinto /usr/share/php/PHP/Timer
+ doins -r src/Timer.php src/{Runtime,}Exception.php
+ newins "${FILESDIR}/autoload-2.1.2.php" autoload.php
+}
+
+pkg_postinst() {
+ ewarn "This library now loads via /usr/share/php/PHP/Timer/autoload.php"
+ ewarn "Please update any scripts to require the autoloader"
+}