summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/json-schema/json-schema-5.2.9.ebuild')
-rw-r--r--dev-php/json-schema/json-schema-5.2.9.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-php/json-schema/json-schema-5.2.9.ebuild b/dev-php/json-schema/json-schema-5.2.9.ebuild
deleted file mode 100644
index 0c8201a0dd70..000000000000
--- a/dev-php/json-schema/json-schema-5.2.9.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DESCRIPTION="PHP implementation of JSON schema"
-HOMEPAGE="https://github.com/justinrainbow/json-schema"
-SRC_URI="https://github.com/justinrainbow/json-schema/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-# Tests are not in the release tarball
-RESTRICT="test"
-
-RDEPEND="
- dev-lang/php:*
- dev-php/fedora-autoloader"
-DEPEND="
- test? (
- ${RDEPEND}
- dev-php/phpunit )"
-
-src_prepare() {
- default
- if use test; then
- cp "${FILESDIR}"/autoload.php "${S}"/autoload-test.php || die
- fi
-}
-
-src_install() {
- insinto "/usr/share/php/JsonSchema"
- doins -r src/JsonSchema/. "${FILESDIR}"/autoload.php
- dodoc README.md
-}
-
-src_test() {
- phpunit --bootstrap "${S}"/autoload-test.php || die "test suite failed"
-}