summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/pecl-crack/pecl-crack-0.4-r6.ebuild')
-rw-r--r--dev-php/pecl-crack/pecl-crack-0.4-r6.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-php/pecl-crack/pecl-crack-0.4-r6.ebuild b/dev-php/pecl-crack/pecl-crack-0.4-r6.ebuild
new file mode 100644
index 000000000000..f7a9d30a87f6
--- /dev/null
+++ b/dev-php/pecl-crack/pecl-crack-0.4-r6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PHP_EXT_NAME="crack"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+PHP_EXT_EXTRA_ECONF=""
+DOCS=( EXPERIMENTAL )
+
+USE_PHP="php5-6 php7-0 php7-1"
+
+inherit php-ext-pecl-r3
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DESCRIPTION="PHP interface to the cracklib libraries"
+LICENSE="PHP-3 CRACKLIB"
+SLOT="0"
+IUSE=""
+# Patch for http://pecl.php.net/bugs/bug.php?id=5765
+PATCHES=( "${FILESDIR}/fix-php-5-4-support.patch"
+"${FILESDIR}/fix-pecl-bug-5765.patch"
+"${FILESDIR}/${PV}-php7.patch"
+)