summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/pecl-haru/pecl-haru-1.0.4-r2.ebuild')
-rw-r--r--dev-php/pecl-haru/pecl-haru-1.0.4-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-php/pecl-haru/pecl-haru-1.0.4-r2.ebuild b/dev-php/pecl-haru/pecl-haru-1.0.4-r2.ebuild
new file mode 100644
index 000000000000..54bd863defc9
--- /dev/null
+++ b/dev-php/pecl-haru/pecl-haru-1.0.4-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+USE_PHP="php5-6"
+
+inherit php-ext-pecl-r3
+
+DESCRIPTION="An interface to libharu, a PDF generator"
+
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="png zlib"
+
+DEPEND="media-libs/libharu[png?,zlib?]"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # config.m4 is broken checking paths, so we need to override it
+ local PHP_EXT_ECONF_ARGS=(
+ $(usex png '--with-png-dir=/usr' '')
+ $(usex zlib '--with-zlib-dir=/usr' '')
+ )
+
+ php-ext-source-r3_src_configure
+}