summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/pecl-oauth/pecl-oauth-2.0.7.ebuild')
-rw-r--r--dev-php/pecl-oauth/pecl-oauth-2.0.7.ebuild13
1 files changed, 5 insertions, 8 deletions
diff --git a/dev-php/pecl-oauth/pecl-oauth-2.0.7.ebuild b/dev-php/pecl-oauth/pecl-oauth-2.0.7.ebuild
index 18221a56290e..bc24d0c0c38e 100644
--- a/dev-php/pecl-oauth/pecl-oauth-2.0.7.ebuild
+++ b/dev-php/pecl-oauth/pecl-oauth-2.0.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -6,7 +6,7 @@ PHP_EXT_NAME="oauth"
PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="no"
-USE_PHP="php7-2 php7-3 php7-4"
+USE_PHP="php8-1"
inherit php-ext-pecl-r3
@@ -17,12 +17,9 @@ LICENSE="BSD"
SLOT="7"
IUSE="+curl examples"
-DEPEND="php_targets_php7-2? ( dev-lang/php:7.2[hash(-)]
- dev-libs/libpcre:3= curl? ( net-misc/curl:0= ) )
- php_targets_php7-3? ( dev-lang/php:7.3[hash(-)]
- dev-libs/libpcre:3= curl? ( net-misc/curl:0= ) )
- php_targets_php7-4? (
- dev-libs/libpcre:3= curl? ( net-misc/curl:0= ) )
+DEPEND="
+ dev-libs/libpcre:3=
+ curl? ( net-misc/curl:0= )
"
RDEPEND="${DEPEND}"