summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/pecl-psr/pecl-psr-1.2.0.ebuild')
-rw-r--r--dev-php/pecl-psr/pecl-psr-1.2.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-php/pecl-psr/pecl-psr-1.2.0.ebuild b/dev-php/pecl-psr/pecl-psr-1.2.0.ebuild
new file mode 100644
index 000000000000..fa1d4bde4514
--- /dev/null
+++ b/dev-php/pecl-psr/pecl-psr-1.2.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PHP_EXT_NAME="psr"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+PHP_EXT_ECONF_ARGS=""
+DOCS=( README.md CHANGELOG.md )
+
+USE_PHP="php7-4 php8-0 php8-1"
+
+inherit php-ext-pecl-r3
+
+KEYWORDS="~amd64"
+
+DESCRIPTION="Provides the accepted PSR interfaces, so they can be used in an extension"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""