summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/pecl-raphf')
-rw-r--r--dev-php/pecl-raphf/Manifest1
-rw-r--r--dev-php/pecl-raphf/metadata.xml2
-rw-r--r--dev-php/pecl-raphf/pecl-raphf-2.0.0-r2.ebuild43
-rw-r--r--dev-php/pecl-raphf/pecl-raphf-2.0.1-r2.ebuild21
-rw-r--r--dev-php/pecl-raphf/pecl-raphf-2.0.1.ebuild40
5 files changed, 22 insertions, 85 deletions
diff --git a/dev-php/pecl-raphf/Manifest b/dev-php/pecl-raphf/Manifest
index 370d4da0588e..fe67b291dc82 100644
--- a/dev-php/pecl-raphf/Manifest
+++ b/dev-php/pecl-raphf/Manifest
@@ -1,2 +1 @@
-DIST raphf-2.0.0.tgz 15715 BLAKE2B bab2997d9ce8358efaa69f2e633f49e4dd16f640e8d30284ebb33767285bead1aabcd973e7133152b82cf624e2c2e68cc6247e424aa5ed540e4211b5ed3da365 SHA512 16b029b694d30817a68a1a9d80bdf031d058ada45a93a4b34b49ec5d61fa8af78d0dbf1a3e5e2f1b950b2a11ac0b86b5a467807551556ab2a77f7f99739ed11b
DIST raphf-2.0.1.tgz 16003 BLAKE2B 4eaf9f89e6572e17e0df347543dc99221f68d45103444f89e59862b9078574722278fbb1e2841b0a5952ffd6dfc4ea0fa81298f2014ffbe8a6b51ed6887f6692 SHA512 0a609fc21a62880963e7afb75297eb75a2598aab2c816cb61e84d665b0453e4952aa9bf25fe2c818cc94492a4b94aed965053c67899fdb984d88661364fffb1e
diff --git a/dev-php/pecl-raphf/metadata.xml b/dev-php/pecl-raphf/metadata.xml
index b86acf66c756..222c77f3742a 100644
--- a/dev-php/pecl-raphf/metadata.xml
+++ b/dev-php/pecl-raphf/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>php-bugs@gentoo.org</email>
diff --git a/dev-php/pecl-raphf/pecl-raphf-2.0.0-r2.ebuild b/dev-php/pecl-raphf/pecl-raphf-2.0.0-r2.ebuild
deleted file mode 100644
index e594718f2c51..000000000000
--- a/dev-php/pecl-raphf/pecl-raphf-2.0.0-r2.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-PHP_EXT_NAME="raphf"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-PHP_EXT_ECONF_ARGS=""
-PHP_INI_NAME="30-${PHP_EXT_NAME}"
-
-USE_PHP="php5-6 php7-1 php7-2 php7-3"
-
-inherit php-ext-pecl-r3
-
-# Only really build for 7.x
-USE_PHP="php7-1 php7-2 php7-3"
-
-KEYWORDS="amd64 x86"
-
-DESCRIPTION="A reusable, persistent handle and resource factory API"
-LICENSE="BSD-2"
-SLOT="7"
-IUSE=""
-
-RDEPEND="php_targets_php5-6? ( ${CATEGORY}/${PN}:0[php_targets_php5-6] )"
-
-# Tests need pecl-http, which needs this
-RESTRICT="test"
-
-src_prepare() {
- if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3; then
- php-ext-source-r3_src_prepare
- else
- default_src_prepare
- fi
-}
-
-src_install() {
- if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3; then
- php-ext-pecl-r3_src_install
- fi
-}
diff --git a/dev-php/pecl-raphf/pecl-raphf-2.0.1-r2.ebuild b/dev-php/pecl-raphf/pecl-raphf-2.0.1-r2.ebuild
new file mode 100644
index 000000000000..3d7ea2841257
--- /dev/null
+++ b/dev-php/pecl-raphf/pecl-raphf-2.0.1-r2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PHP_EXT_NAME="raphf"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+PHP_EXT_ECONF_ARGS=""
+PHP_INI_NAME="30-${PHP_EXT_NAME}"
+
+USE_PHP="php8-1"
+
+inherit php-ext-pecl-r3
+
+KEYWORDS="amd64 x86"
+
+DESCRIPTION="A reusable, persistent handle and resource factory API"
+LICENSE="BSD-2"
+SLOT="7"
+IUSE=""
diff --git a/dev-php/pecl-raphf/pecl-raphf-2.0.1.ebuild b/dev-php/pecl-raphf/pecl-raphf-2.0.1.ebuild
deleted file mode 100644
index 9923b1d0c97d..000000000000
--- a/dev-php/pecl-raphf/pecl-raphf-2.0.1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-PHP_EXT_NAME="raphf"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-PHP_EXT_ECONF_ARGS=""
-PHP_INI_NAME="30-${PHP_EXT_NAME}"
-
-USE_PHP="php5-6 php7-0 php7-1 php7-2 php7-3 php7-4"
-
-inherit php-ext-pecl-r3
-
-# Only really build for 7.x
-USE_PHP="php7-1 php7-2 php7-3 php7-4"
-
-KEYWORDS="~amd64 ~x86"
-
-DESCRIPTION="A reusable, persistent handle and resource factory API"
-LICENSE="BSD-2"
-SLOT="7"
-IUSE=""
-
-RDEPEND="php_targets_php5-6? ( ${CATEGORY}/${PN}:0[php_targets_php5-6] )"
-
-src_prepare() {
- if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-4; then
- php-ext-source-r3_src_prepare
- else
- default_src_prepare
- fi
-}
-
-src_install() {
- if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-4; then
- php-ext-pecl-r3_src_install
- fi
-}