summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/pecl-zmq/pecl-zmq-1.1.3.ebuild')
-rw-r--r--dev-php/pecl-zmq/pecl-zmq-1.1.3.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-php/pecl-zmq/pecl-zmq-1.1.3.ebuild b/dev-php/pecl-zmq/pecl-zmq-1.1.3.ebuild
new file mode 100644
index 000000000000..13dbe35d525e
--- /dev/null
+++ b/dev-php/pecl-zmq/pecl-zmq-1.1.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_PHP="php5-6 php7-0 php7-1"
+
+inherit php-ext-pecl-r3
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="PHP Bindings for ZeroMQ messaging"
+LICENSE="BSD"
+SLOT="0"
+IUSE="czmq"
+
+RDEPEND="net-libs/zeromq czmq? ( <net-libs/czmq-3 )"
+DEPEND="${RDEPEND} virtual/pkgconfig"
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS=( $(use_with czmq) )
+ php-ext-source-r3_src_configure
+}