summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/phar-utils')
-rw-r--r--dev-php/phar-utils/Manifest1
-rw-r--r--dev-php/phar-utils/metadata.xml2
-rw-r--r--dev-php/phar-utils/phar-utils-1.1.2.ebuild22
3 files changed, 24 insertions, 1 deletions
diff --git a/dev-php/phar-utils/Manifest b/dev-php/phar-utils/Manifest
index 791852e8b0a7..43aa84b192f3 100644
--- a/dev-php/phar-utils/Manifest
+++ b/dev-php/phar-utils/Manifest
@@ -1 +1,2 @@
DIST phar-utils-1.1.1.tar.gz 4211 BLAKE2B 370c6e325dcef6fb8ac2ab12a661f59d1c5feb5135aa8bdf7c0b3beb31f90a309994e959b68a96d9da2ea2ae25d38ee5bda1d86a647b4958ce81bece3d02a935 SHA512 bfe7ce821767588032a2db8e2b80d827f33a5bd9049d74d6d1871b7e65878cf78a86162ed67e96edd363a3520f53723bdd496914e96d4ef8629880729bd812e3
+DIST phar-utils-1.1.2.tar.gz 4223 BLAKE2B fa64eb6f6a53f5a571c4cab21235269321055d09c4adb5d72baa1084d862a72f8ac010d1dd02fa8a3e1da4b8b8b449d648cfa4b47486832f85e68f222184518e SHA512 122c76ee29bb981b75f86f025235577bb9c1cf2b3f18c16740a000284a23e04b8ec7ee37a369513f7c44e4da8a8838d90384a02ce38bcb425f826ac2b6eb3b88
diff --git a/dev-php/phar-utils/metadata.xml b/dev-php/phar-utils/metadata.xml
index 3500cb35f8d6..7a2309f32992 100644
--- a/dev-php/phar-utils/metadata.xml
+++ b/dev-php/phar-utils/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person" proxied="yes">
<email>guillaumeseren@gmail.com</email>
diff --git a/dev-php/phar-utils/phar-utils-1.1.2.ebuild b/dev-php/phar-utils/phar-utils-1.1.2.ebuild
new file mode 100644
index 000000000000..e3b6014925d4
--- /dev/null
+++ b/dev-php/phar-utils/phar-utils-1.1.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="PHAR file format utilities, for when PHP phars you up"
+HOMEPAGE="https://github.com/Seldaek/phar-utils"
+SRC_URI="https://github.com/Seldaek/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+
+RDEPEND="
+ dev-lang/php:*[phar]
+ dev-php/fedora-autoloader"
+
+src_install() {
+ insinto "/usr/share/php/Seld/PharUtils"
+ doins -r src/. "${FILESDIR}"/autoload.php
+ dodoc README.md
+}