summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/php-redmine-api/php-redmine-api-1.5.9.ebuild')
-rw-r--r--dev-php/php-redmine-api/php-redmine-api-1.5.9.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-php/php-redmine-api/php-redmine-api-1.5.9.ebuild b/dev-php/php-redmine-api/php-redmine-api-1.5.9.ebuild
deleted file mode 100644
index 0a816cb06bb6..000000000000
--- a/dev-php/php-redmine-api/php-redmine-api-1.5.9.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="A simple, object-oriented, PHP Redmine API client"
-HOMEPAGE="https://github.com/kbsali/php-redmine-api"
-SRC_URI="https://github.com/kbsali/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-lang/php:*[curl,json,simplexml]"
-DEPEND="test? ( ${RDEPEND} <dev-php/phpunit-6 )"
-
-src_install() {
- insinto "/usr/share/php/${PN}"
- doins -r lib
-
- dodoc example.php README.markdown
-}
-
-src_test() {
- phpunit || die "test suite failed"
-}
-
-pkg_postinst() {
- elog "${PN} has been installed in /usr/share/php/${PN}/."
- elog "To use it in a script, require('${PN}/lib/autoload.php'), and then"
- elog "use the Redmine\\Client class normally. Most of the examples in the"
- elog "documentation should work without modification."
-}