summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/phpcov/phpcov-5.0.0.ebuild')
-rw-r--r--dev-php/phpcov/phpcov-5.0.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-php/phpcov/phpcov-5.0.0.ebuild b/dev-php/phpcov/phpcov-5.0.0.ebuild
new file mode 100644
index 000000000000..366e9349d37d
--- /dev/null
+++ b/dev-php/phpcov/phpcov-5.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="CLI frontend for PHP_CodeCoverage"
+HOMEPAGE="https://github.com/sebastianbergmann/phpcov"
+SRC_URI="https://phar.phpunit.de/${P}.phar"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-lang/php:*[phar]
+ dev-php/xdebug"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ return
+}
+
+src_install() {
+ exeinto /usr/share/php/${PN}
+ newexe "${DISTDIR}"/${P}.phar "${PN}.phar"
+ dosym "../share/php/${PN}/${PN}.phar" /usr/bin/${PN}
+}