summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/sebastian-comparator/sebastian-comparator-1.2.4.ebuild')
-rw-r--r--dev-php/sebastian-comparator/sebastian-comparator-1.2.4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-php/sebastian-comparator/sebastian-comparator-1.2.4.ebuild b/dev-php/sebastian-comparator/sebastian-comparator-1.2.4.ebuild
new file mode 100644
index 000000000000..152273611434
--- /dev/null
+++ b/dev-php/sebastian-comparator/sebastian-comparator-1.2.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/sebastian-//}"
+
+DESCRIPTION="Compare PHP values for equality"
+HOMEPAGE="http://phpunit.de"
+SRC_URI="https://github.com/sebastianbergmann/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ <dev-php/sebastian-diff-2.0
+ <dev-php/sebastian-exporter-3.0
+ >=dev-lang/php-5.6:*
+"
+src_install() {
+ insinto /usr/share/php/SebastianBergmann/Comparator
+ doins -r src/*
+ doins "${FILESDIR}/autoload.php"
+}