summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/sebastian-diff/sebastian-diff-1.4.1-r1.ebuild')
-rw-r--r--dev-php/sebastian-diff/sebastian-diff-1.4.1-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-php/sebastian-diff/sebastian-diff-1.4.1-r1.ebuild b/dev-php/sebastian-diff/sebastian-diff-1.4.1-r1.ebuild
new file mode 100644
index 000000000000..c1d9a3ad1779
--- /dev/null
+++ b/dev-php/sebastian-diff/sebastian-diff-1.4.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="diff"
+
+DESCRIPTION="PHP Diff implementation"
+HOMEPAGE="http://phpunit.de"
+SRC_URI="https://github.com/sebastianbergmann/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ >=dev-lang/php-5.6:*"
+
+src_install() {
+ insinto /usr/share/php/SebastianBergmann/Diff
+ doins -r src/*
+ doins "${FILESDIR}/autoload.php"
+}