summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/sebastian-lines-of-code/sebastian-lines-of-code-1.0.3.ebuild')
-rw-r--r--dev-php/sebastian-lines-of-code/sebastian-lines-of-code-1.0.3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-php/sebastian-lines-of-code/sebastian-lines-of-code-1.0.3.ebuild b/dev-php/sebastian-lines-of-code/sebastian-lines-of-code-1.0.3.ebuild
new file mode 100644
index 000000000000..2d708710a6d3
--- /dev/null
+++ b/dev-php/sebastian-lines-of-code/sebastian-lines-of-code-1.0.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="${PN/sebastian-//}"
+
+DESCRIPTION="Library for counting the lines of code in PHP source code"
+HOMEPAGE="https://phpunit.de"
+SRC_URI="https://github.com/sebastianbergmann/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ dev-php/nikic-php-parser
+ >=dev-lang/php-7.3:*"
+
+src_install() {
+ insinto /usr/share/php/SebastianBergmann/LinesOfCode
+ doins -r src/*
+ newins "${FILESDIR}/autoload-1.0.3.php" autoload.php
+}