summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/suhosin')
-rw-r--r--dev-php/suhosin/Manifest1
-rw-r--r--dev-php/suhosin/files/suhosin-0.9.37.1-libcrypt.patch12
-rw-r--r--dev-php/suhosin/files/suhosin-0.9.38-libcrypt.patch12
-rw-r--r--dev-php/suhosin/metadata.xml5
-rw-r--r--dev-php/suhosin/suhosin-0.9.38.ebuild64
5 files changed, 94 insertions, 0 deletions
diff --git a/dev-php/suhosin/Manifest b/dev-php/suhosin/Manifest
new file mode 100644
index 000000000000..4f51b4f6f27e
--- /dev/null
+++ b/dev-php/suhosin/Manifest
@@ -0,0 +1 @@
+DIST suhosin-0.9.38.tar.gz 122800 SHA256 c02d76c4e7ce777910a37c18181cb67fd9e90efe0107feab3de3131b5f89bcea SHA512 cc4eb38b5d6673cc3f2dc395e5a8b5461d3221019ac9849b747b6d5bae423cd5bd01a75b9432414dc7c26c78bab9f2381a5414712a6906a999f3ec9dc77ebc45 WHIRLPOOL db10d0cda4d161440c8dd53f5bbfdcb7da5bdf7e294975a0a3b6f6b69575e16eb43d7fc0aaf3bd9497a8065282b8403e480bc699ee9100574bc212f47f763933
diff --git a/dev-php/suhosin/files/suhosin-0.9.37.1-libcrypt.patch b/dev-php/suhosin/files/suhosin-0.9.37.1-libcrypt.patch
new file mode 100644
index 000000000000..02b5aba1af2b
--- /dev/null
+++ b/dev-php/suhosin/files/suhosin-0.9.37.1-libcrypt.patch
@@ -0,0 +1,12 @@
+Index: suhosin-0.9.32.1/config.m4
+===================================================================
+--- suhosin-0.9.33.orig/config.m4
++++ suhosin-0.9.33/config.m4
+@@ -6,4 +6,7 @@ PHP_ARG_ENABLE(suhosin, whether to enabl
+
+ if test "$PHP_SUHOSIN" != "no"; then
+ PHP_NEW_EXTENSION(suhosin, suhosin.c sha256.c memory_limit.c treat_data.c ifilter.c post_handler.c ufilter.c rfc1867.c rfc1867_new.c log.c header.c execute.c ex_imp.c session.c aes.c crypt.c, $ext_shared)
++ PHP_CHECK_LIBRARY(crypt, crypt,
++ [PHP_ADD_LIBRARY(crypt,, SUHOSIN_SHARED_LIBADD)])
++ PHP_SUBST(SUHOSIN_SHARED_LIBADD)
+ fi
diff --git a/dev-php/suhosin/files/suhosin-0.9.38-libcrypt.patch b/dev-php/suhosin/files/suhosin-0.9.38-libcrypt.patch
new file mode 100644
index 000000000000..691f70c1b4c5
--- /dev/null
+++ b/dev-php/suhosin/files/suhosin-0.9.38-libcrypt.patch
@@ -0,0 +1,12 @@
+Index: suhosin-0.9.32.1/config.m4
+===================================================================
+--- suhosin-0.9.33.orig/config.m4
++++ suhosin-0.9.33/config.m4
+@@ -6,4 +6,7 @@ PHP_ARG_ENABLE(suhosin, whether to enabl
+
+ if test "$PHP_SUHOSIN" != "no"; then
+ PHP_NEW_EXTENSION(suhosin, suhosin.c sha256.c memory_limit.c treat_data.c ifilter.c post_handler.c ufilter.c rfc1867_new.c log.c header.c execute.c ex_imp.c session.c aes.c crypt.c, $ext_shared)
++ PHP_CHECK_LIBRARY(crypt, crypt,
++ [PHP_ADD_LIBRARY(crypt,, SUHOSIN_SHARED_LIBADD)])
++ PHP_SUBST(SUHOSIN_SHARED_LIBADD)
+ fi
diff --git a/dev-php/suhosin/metadata.xml b/dev-php/suhosin/metadata.xml
new file mode 100644
index 000000000000..fd3dbe39fa64
--- /dev/null
+++ b/dev-php/suhosin/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+</pkgmetadata>
diff --git a/dev-php/suhosin/suhosin-0.9.38.ebuild b/dev-php/suhosin/suhosin-0.9.38.ebuild
new file mode 100644
index 000000000000..9f0b7e021744
--- /dev/null
+++ b/dev-php/suhosin/suhosin-0.9.38.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PHP_EXT_NAME="suhosin"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+USE_PHP="php5-6 php5-5 php5-4"
+
+inherit php-ext-source-r2
+
+KEYWORDS="alpha amd64 arm hppa ia64 ~ppc ppc64 ~s390 ~sh sparc x86"
+
+DESCRIPTION="Suhosin is an advanced protection system for PHP installations"
+HOMEPAGE="http://www.suhosin.org/"
+SRC_URI="http://download.suhosin.org/${P}.tar.gz"
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE=""
+
+for target in ${USE_PHP}; do
+ slot=${target/php}
+ slot=${slot/-/.}
+ PHPUSEDEPEND="${PHPUSEDEPEND}
+ php_targets_${target}? ( dev-lang/php:${slot}[unicode] )"
+done
+
+DEPEND="${PHPUSEDEPEND}"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env ${slot}
+ epatch "${FILESDIR}"/${P}-libcrypt.patch
+ done
+ php-ext-source-r2_src_prepare
+}
+
+src_install() {
+ php-ext-source-r2_src_install
+ dodoc CREDITS
+
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env ${slot}
+ for inifile in ${PHPINIFILELIST} ; do
+ insinto "${inifile/${PHP_EXT_NAME}.ini/}"
+ insopts -m644
+ doins "suhosin.ini"
+ done
+ done
+}
+
+src_test() {
+ # Makefile passes a hard-coded -d extension_dir=./modules, we move the lib
+ # away from there in src_compile
+ for slot in `php_get_slots`; do
+ php_init_slot_env ${slot}
+ NO_INTERACTION="yes" emake test || die "emake test failed for slot ${slot}"
+ done
+}