summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/xdebug-handler/xdebug-handler-1.4.1.ebuild')
-rw-r--r--dev-php/xdebug-handler/xdebug-handler-1.4.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-php/xdebug-handler/xdebug-handler-1.4.1.ebuild b/dev-php/xdebug-handler/xdebug-handler-1.4.1.ebuild
new file mode 100644
index 000000000000..806a747fbd38
--- /dev/null
+++ b/dev-php/xdebug-handler/xdebug-handler-1.4.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Restart a CLI process without loading the xdebug extension"
+HOMEPAGE="https://github.com/composer/xdebug-handler"
+SRC_URI="https://github.com/composer/xdebug-handler/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/php:*
+ dev-php/fedora-autoloader
+ >=dev-php/psr-log-1.0.2"
+
+src_install() {
+ insinto /usr/share/php/Composer/XdebugHandler
+ doins src/*.php "${FILESDIR}/autoload.php"
+ dodoc README.md
+}