summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-http/Manifest1
-rw-r--r--dev-php/pecl-http/pecl-http-3.3.0.ebuild74
2 files changed, 0 insertions, 75 deletions
diff --git a/dev-php/pecl-http/Manifest b/dev-php/pecl-http/Manifest
index db040afd7668..c6ecbe7266f4 100644
--- a/dev-php/pecl-http/Manifest
+++ b/dev-php/pecl-http/Manifest
@@ -1,2 +1 @@
-DIST pecl_http-3.3.0.tgz 225653 BLAKE2B b8d3875b2716edda98a2f813e2f5947e65684da12be087b2ec51c405223574b2e44dee3ae0a653a538e9c3acafafcec1ff40778d45d8389b239a1ea4578c2831 SHA512 e774ba0514994f219cbd2d8bef872308be8617ea22894db72473042154842c62d918d4c0b87f8c592182fa81fd1487b672252d587857e1b306dce6d38e2f53fb
DIST pecl_http-4.2.2.tgz 224436 BLAKE2B 26ef3bb38778f0374938ba3f3bddba37c3a2044c7b9ffe2aacbca2566251d26d37882bf66773b8ed62d46855e8f14ad9b577cdb1ef3db9eba9850c0b30e57284 SHA512 1203367d590c7d80ffe7a21e7ac352ba053e3daeb778bf99e08fc13582e665e1429f850e51e36304bdec15e6646b648f2c444b46fa263e5441d008ac41a00f4b
diff --git a/dev-php/pecl-http/pecl-http-3.3.0.ebuild b/dev-php/pecl-http/pecl-http-3.3.0.ebuild
deleted file mode 100644
index 7005edf002ee..000000000000
--- a/dev-php/pecl-http/pecl-http-3.3.0.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="8"
-
-PHP_EXT_NAME="http"
-PHP_EXT_PECL_PKG="pecl_http"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-PHP_INI_NAME="50-http"
-
-USE_PHP="php7-4 php8-0 php8-1"
-
-inherit php-ext-pecl-r3
-
-USE_PHP="php7-4"
-
-KEYWORDS="amd64 x86"
-
-DESCRIPTION="Extended HTTP Support for PHP"
-LICENSE="BSD-2 MIT"
-SLOT="7"
-IUSE="ssl curl_ssl_gnutls curl_ssl_nss +curl_ssl_openssl"
-
-# Patch gets cookies working with curl 7.77, but further interop work was done later
-# Just set min version for this short time to live branch
-COMMON_DEPEND="app-arch/brotli:=
- dev-libs/libevent
- dev-php/pecl-propro:7[php_targets_php7-4(-)?]
- >=dev-php/pecl-raphf-2.0.1:7[php_targets_php7-4(-)?]
- net-dns/libidn2
- sys-libs/zlib
- ssl? ( >=net-misc/curl-7.77[ssl,curl_ssl_gnutls(-)=,curl_ssl_nss(-)=,curl_ssl_openssl(-)=] )
- !ssl? ( >=net-misc/curl-7.77[-ssl] )
-"
-DEPEND="php_targets_php7-4? ( ${COMMON_DEPEND} dev-lang/php:7.4[session(-),iconv(-)] )"
-RDEPEND="${DEPEND}
- php_targets_php8-0? ( dev-php/pecl-http:8[php_targets_php8-0(-)] )
- php_targets_php8-1? ( dev-php/pecl-http:8[php_targets_php8-1(-)] )"
-
-PHP_EXT_ECONF_ARGS=( --with-http --without-http-shared-deps
- --without-http-libidn-dir --without-http-libicu-dir
- --without-http-libidnkit2-dir --without-http-libidnkit-dir )
-
-src_prepare() {
- if use php_targets_php7-4 ; then
- php-ext-source-r3_src_prepare
- else
- default_src_prepare
- fi
-}
-
-src_install() {
- if use php_targets_php7-4 ; then
- php-ext-pecl-r3_src_install
- fi
-}
-
-src_test() {
- # Cannot use eclass function due to required modules
- # All tests SKIP otherwise
- for slot in $(php_get_slots); do
- php_init_slot_env "${slot}"
- # Link in required modules for testing
- ln -s "${EXT_DIR}/propro.so" "modules/propro.so" || die
- ln -s "${EXT_DIR}/raphf.so" "modules/raphf.so" || die
- sed -i \
- 's/PHP_TEST_SHARED_EXTENSIONS)/PHP_TEST_SHARED_EXTENSIONS) -d extension=propro.so -d extension=raphf.so/' \
- Makefile || die
- SKIP_ONLINE_TESTS=yes NO_INTERACTION="yes" emake test
- # Clean up testing links
- rm modules/propro.so modules/raphf.so || die
- done
-}