summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/swoole/Manifest1
-rw-r--r--dev-php/swoole/swoole-4.2.3.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-php/swoole/Manifest b/dev-php/swoole/Manifest
index b156bf06b084..409c1c311b6e 100644
--- a/dev-php/swoole/Manifest
+++ b/dev-php/swoole/Manifest
@@ -1,3 +1,4 @@
DIST swoole-4.0.1.tgz 899395 BLAKE2B 7e7320905cb83794115280977031cc5254a4947781fde05db6e7803f34ff0f5c0ecad84f8aa86adc3c21320b031fa3104fb6c953e9060791dbd9d5c497edbcfc SHA512 0df6ae1bf28ec52abebf1a597c0774e7e5de4bb8378c916a46896c7f84822c8466bbb0d3d188e671e7c39faafa94d2dc2245a468dacb2711c7f0fa617dc42aa8
DIST swoole-4.0.4.tgz 907216 BLAKE2B f078f712c61c7ec9c1a98d94370c892fedd7d1efee7de34438a19d96fea9d41a0553d53fdd34c3d32138c6685045bf45be5fad533b0430b07cb7e60d183433d5 SHA512 b448abeec1fdfe94e0fd5d05b9c2abc7cfc2bb9477d6847adc35cba051d38acfb9ff3bdfaeb10591a50f5a6238f21cef4e0b614e1ff53c71f62b0bcd846d785f
DIST swoole-4.1.1.tgz 930623 BLAKE2B fb4fa99b7b687aeaf4473983659cc2ceb7d8ba9ba6e198b49bea175b28918ebf8316c51f3ab7b4f75a9b7566941ddbba698c0d57f6ee752767c416e68fa68ca1 SHA512 4afc986f6ce362e28085d4ce07c534867311d65be487a66edfb0c01df7cf6e6d2df92abb2aba22b72f2840daade82b5bc3a12883d9cb54fd8ed9e6b0cdf0870f
+DIST swoole-4.2.3.tgz 1127669 BLAKE2B c99b540bf2f5c8757ae8e1b88de5db60bd2fcef0a14faebee3032419645f61c3c54c81f0ced7a4d67701bd1932d962592ea695fd4460d4d5bbb6849a2bb13674 SHA512 37758ff2c8e2638bdd9c5c7ac26ec86e71d71a75c4af0a8ac2c68c81eb74fdbb31e70489b94c50488d25ceeed1731e5f8f74316d5cce3f6e6db41623200416f1
diff --git a/dev-php/swoole/swoole-4.2.3.ebuild b/dev-php/swoole/swoole-4.2.3.ebuild
new file mode 100644
index 000000000000..a5b3c7d3cfb6
--- /dev/null
+++ b/dev-php/swoole/swoole-4.2.3.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PHP_EXT_NAME="swoole"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+PHP_EXT_SAPIS="cli"
+DOCS=( README.md )
+
+USE_PHP="php7-0 php7-1 php7-2 php7-3"
+
+inherit php-ext-pecl-r3
+
+HOMEPAGE="https://www.swoole.co.uk"
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Event-driven asynchronous & concurrent & coroutine networking engine"
+LICENSE="Apache-2.0"
+SLOT="0"
+# Tests can hang. Disable until this no longer happens
+RESTRICT="test"
+
+DEPEND="
+ dev-libs/libaio
+ dev-libs/boost:0=
+ dev-libs/libpcre
+ http2? ( net-libs/nghttp2:0= )
+ redis? ( dev-libs/hiredis:0= )
+ ssl? ( !libressl? ( dev-libs/openssl:0= ) libressl? ( dev-libs/libressl:0= ) )
+ php_targets_php7-0? ( dev-lang/php:7.0[cli,sockets?] )
+ php_targets_php7-1? ( dev-lang/php:7.1[cli,sockets?] )
+ php_targets_php7-2? ( dev-lang/php:7.2[cli,sockets?] )
+ php_targets_php7-3? ( dev-lang/php:7.3[cli,sockets?] )
+ mysql? (
+ php_targets_php7-0? ( dev-lang/php:7.0[mysql,mysqli(+)] )
+ php_targets_php7-1? ( dev-lang/php:7.1[mysql,mysqli(+)] )
+ php_targets_php7-2? ( dev-lang/php:7.2[mysql,mysqli(+)] )
+ php_targets_php7-3? ( dev-lang/php:7.3[mysql,mysqli(+)] )
+ )
+"
+
+RDEPEND="${DEPEND}"
+
+IUSE="debug http2 libressl mysql redis sockets ssl threads"
+
+src_configure() {
+ # PostgreSQL disabled due to Gentoo's slot system
+ # JEMalloc not included as it refuses to find a ${EROOT}usr/includes/jemalloc subdirectory
+ local PHP_EXT_ECONF_ARGS=(
+ --enable-swoole
+ --disable-coroutine-postgresql
+ $(use_enable debug)
+ $(use_enable http2)
+ $(use_enable mysql mysqlnd)
+ $(use_enable redis async_redis)
+ $(use_enable ssl openssl)
+ $(use_with ssl openssl-dir "${EROOT%/}/usr")
+ $(use_enable threads thread)
+ $(use_enable sockets)
+ )
+
+ php-ext-source-r3_src_configure
+}
+
+src_test() {
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env "${slot}"
+ [[ -f tests/template.phpt ]] && rm tests/template.phpt
+ SKIP_ONLINE_TESTS="yes" NO_INTERACTION="yes" emake test
+ done
+}