summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/Babel')
-rw-r--r--dev-python/Babel/Babel-2.13.1.ebuild69
-rw-r--r--dev-python/Babel/Manifest1
2 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/Babel/Babel-2.13.1.ebuild b/dev-python/Babel/Babel-2.13.1.ebuild
new file mode 100644
index 000000000000..b2e3db74dd6d
--- /dev/null
+++ b/dev-python/Babel/Babel-2.13.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+# see scripts/download_import_cldr.py
+CLDR_PV=42.0
+DESCRIPTION="Collection of tools for internationalizing Python applications"
+HOMEPAGE="
+ https://babel.pocoo.org/
+ https://pypi.org/project/Babel/
+ https://github.com/python-babel/babel/
+"
+SRC_URI+="
+ https://unicode.org/Public/cldr/${CLDR_PV%.*}/cldr-common-${CLDR_PV}.zip
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+# RDEPEND in BDEPEND for import_cldr.py usage, bug #852158
+BDEPEND="
+ app-arch/unzip
+ ${RDEPEND}
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+src_prepare() {
+ rm babel/locale-data/*.dat || die
+ rm babel/global.dat || die
+ distutils-r1_src_prepare
+}
+
+python_configure() {
+ if [[ ! -f babel/global.dat ]]; then
+ "${EPYTHON}" scripts/import_cldr.py "${WORKDIR}"/common || die
+ fi
+}
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ if [[ ${EPYTHON} == python3.12 ]]; then
+ EPYTEST_DESELECT+=(
+ # seems to be a corner case, might be a regression in cpython
+ # https://github.com/python-babel/babel/issues/1005
+ tests/messages/test_extract.py::ExtractPythonTestCase::test_utf8_message_with_utf8_bom
+ tests/messages/test_extract.py::ExtractPythonTestCase::test_utf8_message_with_utf8_bom_and_magic_comment
+ tests/messages/test_extract.py::ExtractPythonTestCase::test_utf8_raw_strings_match_unicode_strings
+ tests/messages/test_extract.py::ExtractTestCase::test_f_strings
+ tests/messages/test_extract.py::ExtractTestCase::test_f_strings_non_utf8
+ )
+ fi
+
+ local -x TZ=UTC
+ epytest
+}
diff --git a/dev-python/Babel/Manifest b/dev-python/Babel/Manifest
index a268d743f2f9..90bf16850e12 100644
--- a/dev-python/Babel/Manifest
+++ b/dev-python/Babel/Manifest
@@ -1,3 +1,4 @@
DIST Babel-2.12.1.tar.gz 9906735 BLAKE2B d78838f9a2032eae998f1d751ad803fec81c03be498db934e34e0702d28e0815a7848e55af73ea4dff45e3cf063b9e45ab06c749b8d3f15b7742e209bf3d06ef SHA512 93c4bf343d99a1f47f43f8b828eb79098cb429bac1034d58b5aa49adff68116e458067f3784d997f34515828a7432fd18f7abbaeee59b47a4ee8ea744908b33b
DIST Babel-2.13.0.tar.gz 9909829 BLAKE2B d30aa56a1aba0c3caaa8fdc9210ca3a21fd70b6687c86de23f63cc2af7e1c4d3d1f00a8fc5287480808b643c21dc997992fddfb9d038248d762137453f0bdb72 SHA512 43f4b5fdd8653639111a767c4b082333d89695507e92c3fca88262f23ee7531d4600ec794e908e78a64da1ec54020c7127df3deaf979e15c4e1067cdb839aa47
+DIST Babel-2.13.1.tar.gz 9909844 BLAKE2B f4e0cb6d19c2ecd24a8e67e7d77531248cb5a8d100a5da2a9fe147aef3c15339728c82d4fe9095563c0a0b83dede7c5e27f29281bc3bf0cac5deff7cce409335 SHA512 c27c76456094927bd43ae46cd3e08fcc729dd810a6092da6c86e863523c10746bb3759e7fc9f5396504ab914743ef013904b63b3aa63338602f23aaf83d42cba
DIST cldr-common-42.0.zip 30178050 BLAKE2B 076e3eca12534feff8e0e54bdc1fa38fc0db0f78cac8b4e35b343763a8ac6787745aa36be165684f4d6dda423409c4431a8e4941c53ae7d340ead0b35edbca30 SHA512 315448fe6a9ac2d5a6a7fd1a27b38c5db30fed053654a803d50e3a8d06aa08ad153e8e57089fa094c561f41a54f37eecda0701b47a1813879902be71945aa38a