summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/CppHeaderParser')
-rw-r--r--dev-python/CppHeaderParser/CppHeaderParser-2.7.4-r1.ebuild24
-rw-r--r--dev-python/CppHeaderParser/CppHeaderParser-2.7.4.ebuild19
-rw-r--r--dev-python/CppHeaderParser/metadata.xml2
3 files changed, 25 insertions, 20 deletions
diff --git a/dev-python/CppHeaderParser/CppHeaderParser-2.7.4-r1.ebuild b/dev-python/CppHeaderParser/CppHeaderParser-2.7.4-r1.ebuild
new file mode 100644
index 000000000000..1b313949b2d3
--- /dev/null
+++ b/dev-python/CppHeaderParser/CppHeaderParser-2.7.4-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Parse C++ header files and generate a data structure"
+HOMEPAGE="
+ https://senexcanis.com/open-source/cppheaderparser/
+ https://pypi.org/project/CppHeaderParser/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/ply[${PYTHON_USEDEP}]
+"
diff --git a/dev-python/CppHeaderParser/CppHeaderParser-2.7.4.ebuild b/dev-python/CppHeaderParser/CppHeaderParser-2.7.4.ebuild
deleted file mode 100644
index ec77d48706e2..000000000000
--- a/dev-python/CppHeaderParser/CppHeaderParser-2.7.4.ebuild
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Parse C++ header files and generate a data structure"
-HOMEPAGE="https://senexcanis.com/open-source/cppheaderparser"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="dev-python/ply[${PYTHON_USEDEP}]"
-
-DEPEND="${RDEPEND}"
diff --git a/dev-python/CppHeaderParser/metadata.xml b/dev-python/CppHeaderParser/metadata.xml
index 61f70a8c2a71..3e107817dd7b 100644
--- a/dev-python/CppHeaderParser/metadata.xml
+++ b/dev-python/CppHeaderParser/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>sci@gentoo.org</email>