summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/GitPython')
-rw-r--r--dev-python/GitPython/GitPython-3.1.18.ebuild66
-rw-r--r--dev-python/GitPython/GitPython-3.1.43.ebuild (renamed from dev-python/GitPython/GitPython-3.1.19.ebuild)41
-rw-r--r--dev-python/GitPython/Manifest10
-rw-r--r--dev-python/GitPython/metadata.xml2
4 files changed, 28 insertions, 91 deletions
diff --git a/dev-python/GitPython/GitPython-3.1.18.ebuild b/dev-python/GitPython/GitPython-3.1.18.ebuild
deleted file mode 100644
index 2b4965f449ee..000000000000
--- a/dev-python/GitPython/GitPython-3.1.18.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-TEST_P=GitPython-${PV}
-GITDB_P=gitdb-4.0.7
-SMMAP_P=smmap-4.0.0
-
-DESCRIPTION="Library used to interact with Git repositories"
-HOMEPAGE="https://github.com/gitpython-developers/GitPython https://pypi.org/project/GitPython/"
-SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz
- test? (
- https://dev.gentoo.org/~mgorny/dist/${TEST_P}.gitbundle
- https://dev.gentoo.org/~mgorny/dist/${GITDB_P}.gitbundle
- https://dev.gentoo.org/~mgorny/dist/${SMMAP_P}.gitbundle
- )"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc64 x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- dev-vcs/git
- >=dev-python/gitdb-4.0.1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/typing-extensions[${PYTHON_USEDEP}]
- ' python3_7)"
-BDEPEND="
- test? (
- >=dev-python/ddt-1.1.1[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests unittest
-
-src_test() {
- git config --global user.email "travis@ci.com" || die
- git config --global user.name "Travis Runner" || die
-
- git clone "${DISTDIR}/${TEST_P}.gitbundle" "${T}"/test || die
- git clone "${DISTDIR}/${GITDB_P}.gitbundle" \
- "${T}"/test/git/ext/gitdb || die
- git clone "${DISTDIR}/${SMMAP_P}.gitbundle" \
- "${T}"/test/git/ext/gitdb/gitdb/ext/smmap || die
-
- cd "${T}"/test || die
- git rev-parse HEAD > .git/refs/remotes/origin/master || die
- TRAVIS=1 ./init-tests-after-clone.sh || die
- cat test/fixtures/.gitconfig >> ~/.gitconfig || die
- rm -r test/performance || die
- # tests requiring network access
- sed -i -e 's:test_fetch_error:_&:' test/test_remote.py || die
- sed -i -e 's:test_leaking_password_in_clone_logs:_&:' test/test_repo.py || die
- # TODO
- sed -e 's:test_root_module:_&:' \
- -e 's:test_base_rw:_&:' \
- -i test/test_submodule.py || die
- rm test/test_installation.py || die
-
- distutils-r1_src_test
-}
diff --git a/dev-python/GitPython/GitPython-3.1.19.ebuild b/dev-python/GitPython/GitPython-3.1.43.ebuild
index 87d5f7d31add..29051eb6c6da 100644
--- a/dev-python/GitPython/GitPython-3.1.19.ebuild
+++ b/dev-python/GitPython/GitPython-3.1.43.ebuild
@@ -1,40 +1,46 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
PYTHON_REQ_USE="threads(+)"
-inherit distutils-r1
+inherit distutils-r1 pypi
TEST_P=GitPython-${PV}
-GITDB_P=gitdb-4.0.7
-SMMAP_P=smmap-4.0.0
+GITDB_P=gitdb-4.0.11
+SMMAP_P=smmap-5.0.1
DESCRIPTION="Library used to interact with Git repositories"
-HOMEPAGE="https://github.com/gitpython-developers/GitPython https://pypi.org/project/GitPython/"
-SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz
+HOMEPAGE="
+ https://github.com/gitpython-developers/GitPython/
+ https://pypi.org/project/GitPython/
+"
+SRC_URI+="
test? (
https://dev.gentoo.org/~mgorny/dist/${TEST_P}.gitbundle
https://dev.gentoo.org/~mgorny/dist/${GITDB_P}.gitbundle
https://dev.gentoo.org/~mgorny/dist/${SMMAP_P}.gitbundle
- )"
+ )
+"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
RDEPEND="
dev-vcs/git
>=dev-python/gitdb-4.0.1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/typing-extensions[${PYTHON_USEDEP}]
- ' python3_7)"
+"
BDEPEND="
test? (
>=dev-python/ddt-1.1.1[${PYTHON_USEDEP}]
- )"
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
distutils_enable_tests pytest
@@ -52,23 +58,22 @@ src_test() {
git rev-parse HEAD > .git/refs/remotes/origin/master || die
TRAVIS=1 ./init-tests-after-clone.sh || die
cat test/fixtures/.gitconfig >> ~/.gitconfig || die
- sed -i -e '/addopts/d' pyproject.toml || die
distutils-r1_src_test
}
python_test() {
- local deselect=(
+ local EPYTEST_DESELECT=(
# performance tests are unreliable by design
test/performance
- # unimpoortant and problematic
+ # unimportant and problematic
test/test_installation.py
# Internet
- test/test_repo.py::TestRepo::test_leaking_password_in_clone_logs
+ test/test_quick_doc.py::QuickDoc::test_cloned_repo_object
# TODO
test/test_submodule.py::TestSubmodule::test_base_rw
test/test_submodule.py::TestSubmodule::test_root_module
)
- epytest ${deselect[@]/#/--deselect }
+ epytest -o addopts= test
}
diff --git a/dev-python/GitPython/Manifest b/dev-python/GitPython/Manifest
index 04b9f066ce5b..7e514497ee52 100644
--- a/dev-python/GitPython/Manifest
+++ b/dev-python/GitPython/Manifest
@@ -1,6 +1,4 @@
-DIST GitPython-3.1.18.gitbundle 9129652 BLAKE2B df2ea8fa06d4209c532a239fa5bebde29314b467811526f67629f181a62b2b5ba235a3302b979dfd87993deca238a91820b3caa58fcb7cf3aaffc3bf76b0c731 SHA512 91fd937193db8a948fb575bf24a295c349e69b132128ed3b0c4fc3be89feb76ff47f31afe422c99ccbee4cf908b3040e9dd3f568db74785d12cf6cabbc356daa
-DIST GitPython-3.1.18.tar.gz 181199 BLAKE2B ac50cee78b5980c6d23ec60786e8d279558a2740480e0975c212de8d96abd58da95de8d66bc9c7c3f0c7d1baa1757460f36df53552b06bd6323d3f882d0b90ae SHA512 981b3f4eec71c4e1de6efa2381c3c411aedfc51918f9f58f397926d21dabdfabb54d498ae44a5b6ceca59adf99e866df8d04f97a86df942e81408a5a0e751a15
-DIST GitPython-3.1.19.gitbundle 9507079 BLAKE2B 7f9304c45784ddb779642df6b4412d022dad5ee20f89e998281db426928ee7bfafadb9a849e174c7cf850b049697ac097e1d144ca40f86497c6bab03e32ede8b SHA512 1fa8b01b27a993221ba4771aca416c724c12c208169fe4a6e08666ebf20c8dd870eb01f039d33ed13d664df5c6126cc4477994092ceeea64fc77f28a68cd9279
-DIST GitPython-3.1.19.tar.gz 187639 BLAKE2B 835a43edc7adfbb6253abb904d2f313bb597418c749473e6ce5deef67e546ee5285146a3a8c34d6afc4f56345e3e6a6481899465c8598b5215dbadb59b0bd507 SHA512 019a558fbc60c540872451ae1cd5ab029d5b3c5d5ed4979dadaa0e1829548e04bba62173a85d8fceddab5a19bc83e1750d938f73e984a64747550e6936400c9e
-DIST gitdb-4.0.7.gitbundle 1498536 BLAKE2B 1e0aff67259c04d2932dbdefb0ae07bd9fb51c5dcb99ee8431e78bf428095250ed45f5e12e2484b407bb4257050b0864e67096b3501d4829491cb7714a7b5ddf SHA512 f8b1b3de00f0597d65f528dd30495fd3dd9e1e4d494987899ef2064d23947ede799db391a59688dfa27e4fcdc9379b5352a378b39e6fb2421e6c850f81157bec
-DIST smmap-4.0.0.gitbundle 322820 BLAKE2B 20ac688cafa9ad036f3e21ac1bb9323ae55e618eb0806634fe4c885d2b12fe802779adcffb0fea3da9707e94109a168738d63abe990d1ce9b141c779aa6798d6 SHA512 03296099303eb38ac9ca46733255024355aed2e64a2f9409552ae34af76beb9685a6dd2458df986593fe426e428bc184617abe22c8b92ee01c8c7e1d98de8592
+DIST GitPython-3.1.43.gitbundle 10674326 BLAKE2B c430e6fec138077502dce16a1a100459c30134af7865a2e228646791465a7176ee3ef4db5cc83081f56b5e9877aeb4ba7e54b0526d6c2f594520335db4b48e9e SHA512 8c4b2fdf2e382393420bee1cb19929171d72e72669ac3ef96ff112119d803775aae92a14908b9bd51873f102ab85dfadd940b0789da6179b0f99354ae4b6d469
+DIST GitPython-3.1.43.tar.gz 214149 BLAKE2B bc95520b839a43b88571678d7dadd3998a613a4e4f5b0e59f8740add7794767db2820e2d68a98940976ed27fa57b6e487895b1f3d2894b55f1d7f4e06757a461 SHA512 c193418bbb6ebb4f202c4f6aa95b731acf319d6560db176aa7126cf848a1f11eea9f432c4ff6812e8ddb5f8386b1fa5e10335fbf170f3ec3ac5fd2dcde783415
+DIST gitdb-4.0.11.gitbundle 1620355 BLAKE2B 8095193318d4262b8ebb04f35a0500eda8757057ed472dbaaece53e6afa6227e2b2c02a2be5daa5e4c0cc43dcbb5046555407d3d7c8dbed0bc5c415515032b8d SHA512 17e404b335a3c081f4058aeba5c57e5697a580f8ad7a280fde868968cf48f5a0852bfa45019eab730279582c0c536f8204e973d93af09da05908477329d73360
+DIST smmap-5.0.1.gitbundle 362567 BLAKE2B 72c8b48ad3250a33b94218c145c02033dee84c1da5f1eea57983a58699262d51844be675330d95c7d64924b6aeaacd4b0a57e9a5acad3be184aaad62102202e7 SHA512 9ca8386bfec25d1562cdf1c2ee85f7edb15fd3f44ecd1abbef738979f12b82f0b0f39a06589203a39f89518d981d7129e35f64f2d855cd162cd964bdd87c8d18
diff --git a/dev-python/GitPython/metadata.xml b/dev-python/GitPython/metadata.xml
index 1e0c7269c568..3c5dfe92db61 100644
--- a/dev-python/GitPython/metadata.xml
+++ b/dev-python/GitPython/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>python@gentoo.org</email>