summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/GridDataFormats/GridDataFormats-0.4.0-r1.ebuild')
-rw-r--r--dev-python/GridDataFormats/GridDataFormats-0.4.0-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/GridDataFormats/GridDataFormats-0.4.0-r1.ebuild b/dev-python/GridDataFormats/GridDataFormats-0.4.0-r1.ebuild
new file mode 100644
index 000000000000..8fa5ff05c2ea
--- /dev/null
+++ b/dev-python/GridDataFormats/GridDataFormats-0.4.0-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Reading and writing of data on regular grids in Python"
+HOMEPAGE="https://pypi.org/project/GridDataFormats/ https://github.com/MDAnalysis/GridDataFormats"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ >=dev-python/numpy-1.0.3[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]"