summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/PeachPy/PeachPy-2022.11.13-r2.ebuild')
-rw-r--r--dev-python/PeachPy/PeachPy-2022.11.13-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/PeachPy/PeachPy-2022.11.13-r2.ebuild b/dev-python/PeachPy/PeachPy-2022.11.13-r2.ebuild
new file mode 100644
index 000000000000..395c7459ef5f
--- /dev/null
+++ b/dev-python/PeachPy/PeachPy-2022.11.13-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} )
+inherit distutils-r1
+
+CommitId=349e8f836142b2ed0efeb6bb99b1b715d87202e9
+
+DESCRIPTION="Portable Efficient Assembly Code-generator in Higher-level Python"
+HOMEPAGE="https://pypi.org/project/PeachPy/"
+SRC_URI="https://github.com/Maratyszcza/${PN}/archive/${CommitId}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test" # depends on an old version of werkzeug
+
+RDEPEND="
+ dev-python/Opcodes[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${PN}-${CommitId}
+
+DOCS=README.rst
+
+distutils_enable_sphinx sphinx \
+ dev-python/sphinx-bootstrap-theme