summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/PyQt6/PyQt6-6.4.2.ebuild')
-rw-r--r--dev-python/PyQt6/PyQt6-6.4.2.ebuild2
1 files changed, 2 insertions, 0 deletions
diff --git a/dev-python/PyQt6/PyQt6-6.4.2.ebuild b/dev-python/PyQt6/PyQt6-6.4.2.ebuild
index ccee7f8cdba7..cf5de2a490c4 100644
--- a/dev-python/PyQt6/PyQt6-6.4.2.ebuild
+++ b/dev-python/PyQt6/PyQt6-6.4.2.ebuild
@@ -78,7 +78,9 @@ src_prepare() {
}
src_configure() {
+ append-cppflags $(usex debug -{U,D}NDEBUG) # not set by eclass "yet"
append-cxxflags -std=c++17 # for old gcc / clang that use <17 (bug #892331)
+ append-cxxflags ${CPPFLAGS} # respect CPPFLAGS
pyqt-use_enable() {
local state=$(usex ${1} --enable= --disable=)