summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/PySocks')
-rw-r--r--dev-python/PySocks/PySocks-1.7.1-r1.ebuild50
-rw-r--r--dev-python/PySocks/PySocks-1.7.1-r2.ebuild21
-rw-r--r--dev-python/PySocks/files/PySocks-1.7.1-test_server.patch33
-rw-r--r--dev-python/PySocks/metadata.xml2
4 files changed, 22 insertions, 84 deletions
diff --git a/dev-python/PySocks/PySocks-1.7.1-r1.ebuild b/dev-python/PySocks/PySocks-1.7.1-r1.ebuild
deleted file mode 100644
index a3486b012e0d..000000000000
--- a/dev-python/PySocks/PySocks-1.7.1-r1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="SOCKS client module"
-HOMEPAGE="https://github.com/Anorov/PySocks https://pypi.org/project/PySocks/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-#BDEPEND="
-# test? (
-# net-proxy/3proxy
-# $(python_gen_cond_dep 'dev-python/test_server[${PYTHON_USEDEP}]' -3)
-# )"
-
-#distutils_enable_tests pytest
-
-# tests fail semi-randomly; probably starting proxy server doesn't work
-# as expected
-RESTRICT="test"
-
-src_prepare() {
- local PATCHES=(
- "${FILESDIR}"/PySocks-1.7.1-test_server.patch
- )
-
- rm test/bin/3proxy || die
-# if use test; then
-# ln -s "${BROOT}/usr/bin/3proxy" test/bin/3proxy || die
-# fi
-
- # requires Internet
- sed -i -e 's:test_socks5_proxy_connect_timeout:_&:' \
- test/test_pysocks.py || die
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- python_is_python3 || return
- pytest -vv || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/PySocks/PySocks-1.7.1-r2.ebuild b/dev-python/PySocks/PySocks-1.7.1-r2.ebuild
new file mode 100644
index 000000000000..eb503cb2a644
--- /dev/null
+++ b/dev-python/PySocks/PySocks-1.7.1-r2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="SOCKS client module"
+HOMEPAGE="https://github.com/Anorov/PySocks https://pypi.org/project/PySocks/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+# tests are broken beyond repair and the package is no longer maintained
+RESTRICT="test"
diff --git a/dev-python/PySocks/files/PySocks-1.7.1-test_server.patch b/dev-python/PySocks/files/PySocks-1.7.1-test_server.patch
deleted file mode 100644
index 20d208549720..000000000000
--- a/dev-python/PySocks/files/PySocks-1.7.1-test_server.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From 983f0451ed25c755da670a682703ae8f7795782b Mon Sep 17 00:00:00 2001
-From: John Vandenberg <jayvdb@gmail.com>
-Date: Wed, 4 Dec 2019 10:44:14 +0700
-Subject: [PATCH] Update tests for test-server 0.0.31
-
-Closes https://github.com/Anorov/PySocks/issues/117
----
- requirements_dev.txt | 2 +-
- test/test_pysocks.py | 4 ++--
- 2 files changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/test/test_pysocks.py b/test/test_pysocks.py
-index 49893b2..03d2649 100644
---- a/test/test_pysocks.py
-+++ b/test/test_pysocks.py
-@@ -79,8 +79,7 @@ def setUpClass(cls):
- from test_server import TestServer
-
- cls.test_server = TestServer(address=TEST_SERVER_HOST,
-- port=TEST_SERVER_PORT,
-- engine='subprocess')
-+ port=TEST_SERVER_PORT)
- cls.test_server.start()
-
- @classmethod
-@@ -112,6 +111,7 @@ def assert_proxy_response(self, resp_data, content, address,
- self.test_server.request['headers']['user-agent'])
- self.assertEqual('%s:%d' % address,
- self.test_server.request['headers']['host'])
-+ content = b'3\r\n' + content + b'\r\n0'
- self.assertEqual(content, resp_body)
- self.assertEqual(client_ip or PROXY_HOST_IP,
- self.test_server.request['client_ip'])
diff --git a/dev-python/PySocks/metadata.xml b/dev-python/PySocks/metadata.xml
index 3c41a6b6471f..869cadcf8955 100644
--- a/dev-python/PySocks/metadata.xml
+++ b/dev-python/PySocks/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>python@gentoo.org</email>