summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/WSME/WSME-0.10.0.ebuild')
-rw-r--r--dev-python/WSME/WSME-0.10.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/WSME/WSME-0.10.0.ebuild b/dev-python/WSME/WSME-0.10.0.ebuild
new file mode 100644
index 000000000000..e80a811bb69c
--- /dev/null
+++ b/dev-python/WSME/WSME-0.10.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_7 python3_8 )
+
+inherit distutils-r1
+
+DESCRIPTION="Simplify the writing of REST APIs, and extend them with additional protocols."
+HOMEPAGE="https://pythonhosted.org/WSME"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND=">=dev-python/pbr-1.3[${PYTHON_USEDEP}]"
+RDEPEND="
+ >=dev-python/pbr-1.3[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/webob-1.8.0[${PYTHON_USEDEP}]
+ dev-python/simplegeneric[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.12[${PYTHON_USEDEP}]
+"