summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/agate-excel/agate-excel-0.4.1.ebuild')
-rw-r--r--dev-python/agate-excel/agate-excel-0.4.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/agate-excel/agate-excel-0.4.1.ebuild b/dev-python/agate-excel/agate-excel-0.4.1.ebuild
new file mode 100644
index 000000000000..2b80eb5db7e5
--- /dev/null
+++ b/dev-python/agate-excel/agate-excel-0.4.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Adds read support for Excel files (xls and xlsx) to agate"
+HOMEPAGE="
+ https://github.com/wireservice/agate-excel/
+ https://pypi.org/project/agate-excel/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/agate-1.5.0[${PYTHON_USEDEP}]
+ dev-python/olefile[${PYTHON_USEDEP}]
+ >=dev-python/openpyxl-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/xlrd-0.9.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest