summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/aiohttp/aiohttp-3.9.1.ebuild')
-rw-r--r--dev-python/aiohttp/aiohttp-3.9.1.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/dev-python/aiohttp/aiohttp-3.9.1.ebuild b/dev-python/aiohttp/aiohttp-3.9.1.ebuild
index 52c9a3b75738..f878b034c59f 100644
--- a/dev-python/aiohttp/aiohttp-3.9.1.ebuild
+++ b/dev-python/aiohttp/aiohttp-3.9.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -40,8 +40,8 @@ BDEPEND="
dev-python/pytest-forked[${PYTHON_USEDEP}]
dev-python/pytest-mock[${PYTHON_USEDEP}]
dev-python/pytest-xdist[${PYTHON_USEDEP}]
- dev-python/re-assert[${PYTHON_USEDEP}]
$(python_gen_cond_dep '
+ dev-python/re-assert[${PYTHON_USEDEP}]
dev-python/time-machine[${PYTHON_USEDEP}]
' 'python3*')
test-rust? (
@@ -107,6 +107,14 @@ python_test() {
# on PyPy3 but the test suite needs an explicit switch,
# sigh
local -x AIOHTTP_NO_EXTENSIONS=1
+
+ EPYTEST_IGNORE+=(
+ # Skip tests requiring dev-python/re-assert -> dev-python/regex
+ tests/test_streams.py
+ tests/test_urldispatch.py
+ tests/test_client_session.py
+ tests/test_web_response.py
+ )
;;
esac