summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/aioresponses')
-rw-r--r--dev-python/aioresponses/Manifest1
-rw-r--r--dev-python/aioresponses/aioresponses-0.7.6.ebuild38
-rw-r--r--dev-python/aioresponses/metadata.xml14
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/aioresponses/Manifest b/dev-python/aioresponses/Manifest
new file mode 100644
index 000000000000..d190a80a4dbf
--- /dev/null
+++ b/dev-python/aioresponses/Manifest
@@ -0,0 +1 @@
+DIST aioresponses-0.7.6.tar.gz 35846 BLAKE2B f5cb820ee410e1203526ac6731c73f02993684679d788c8e3db830189d9874991b6fabf2e0738d14d3e54e2fa2b44af788f054137590ffea78df49056389673b SHA512 d02fa848a5d6588e32c203591f842cb212aae60d5e060a3fa13993bbb575922e516f04d47f9428c5f4b8103bc9990aa45cdde3c17bd2c47d8eff714f93976450
diff --git a/dev-python/aioresponses/aioresponses-0.7.6.ebuild b/dev-python/aioresponses/aioresponses-0.7.6.ebuild
new file mode 100644
index 000000000000..9af64863e3e4
--- /dev/null
+++ b/dev-python/aioresponses/aioresponses-0.7.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Helper to mock/fake web requests in Python's aiohttp package"
+HOMEPAGE="
+ https://github.com/pnuckowski/aioresponses/
+ https://pypi.org/project/aioresponses/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~riscv x86"
+
+RDEPEND="
+ >=dev-python/aiohttp-3.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ dev-python/ddt[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # These tests require Internet access
+ tests/test_aioresponses.py::AIOResponsesTestCase::test_address_as_instance_of_url_combined_with_pass_through
+ tests/test_aioresponses.py::AIOResponsesTestCase::test_pass_through_with_origin_params
+)
diff --git a/dev-python/aioresponses/metadata.xml b/dev-python/aioresponses/metadata.xml
new file mode 100644
index 000000000000..d9e3184976a3
--- /dev/null
+++ b/dev-python/aioresponses/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">aioresponses</remote-id>
+ <remote-id type="github">pnuckowski/aioresponses</remote-id>
+ <bugs-to>https://github.com/pnuckowski/aioresponses/issues</bugs-to>
+ </upstream>
+</pkgmetadata>