summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/aiorpcX/aiorpcX-0.22.0.ebuild')
-rw-r--r--dev-python/aiorpcX/aiorpcX-0.22.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/aiorpcX/aiorpcX-0.22.0.ebuild b/dev-python/aiorpcX/aiorpcX-0.22.0.ebuild
new file mode 100644
index 000000000000..8ba0167288fa
--- /dev/null
+++ b/dev-python/aiorpcX/aiorpcX-0.22.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Generic async RPC implementation, including JSON-RPC"
+HOMEPAGE="https://pypi.org/project/aiorpcX/
+ https://github.com/kyuupichan/aiorpcX/"
+SRC_URI="https://github.com/kyuupichan/aiorpcX/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/uvloop[${PYTHON_USEDEP}]
+ dev-python/websockets[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # require Internet
+ tests/test_socks.py::TestSOCKSProxy::test_create_connection_resolve_good
+ )
+
+ epytest ${deselect[@]/#/--deselect }
+}